Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.

Log in or register to post/reply in the forum.

Problem with the use of a constant in WindVector instruction - CR1000X

luisfgranada Jun 23, 2022 10:08 AM


There was a change in firmware 5.0 from CR1000X that affected some of our measurements. In the past, we were doing the following: 

Const ws_aux = 1.0

Public SE_1
Public SE_2
Public wd

DataTable (Main,1,-1)
	DataInterval (0,10,Min,10)

	WindVector (1,ws_aux,wd,IEEE4,False,0,0,0)
	FieldNames ("wd_VecSpd_Avg:,wd_VecDir_Avg:,wd_VecDir_Std:")

	Scan (1,Sec,0,0)

		VoltSe (SE_1,1,mV5000,1,True ,0,_50Hz,1.0,0)
		VoltSe (SE_2,1,mV5000,2,True ,0,_50Hz,1.0,0)
		wd = (SE_1/SE_2*369)

		CallTable Main

Everything was working fine but when we updated the firmware in our dataloggers, and kept the same programs, we noticed that wd_VecDir_Avg is always zero. After some testing we came out to the conclussion that the issue happens when:

1. Parameter "Speed/East" from WindVector instruction is a constant.

2. Patameter "OutputOpt" from WindVector instruction is 0

In order to solve this problem we had to update the programs in dataloggers with firmware >= 5.0 to change the line:

Const ws_aux = 1.0


Dim ws_aux = 1.0

This solved the problem and now we get correct Vector Mean Wind Direction values.

I tried contacting our sales representative but the conversation got nowhere.

Can anyone from Campbell please tell me why this happens? In the revision history from firmware 5.0 I didn't find anything about this. Can this be fixed in a newer version so WindVector produces Vector Mean Wind Direction values that are correct and not zero? Some colleagues have reused old programs (Const ws_aux = 1.0) in dataloggers with latest firmware (6.0) and we still have the same problem.


Log in or register to post/reply in the forum.