Our full technical support staff does not monitor this forum. If you need assistance from a member of our staff, please submit your question from the Ask a Question page.

Log in or register to post/reply in the forum.

PPP connection to CR1000 via Sierra Wireless Airlink LS300

bugguts99 Nov 14, 2016 02:37 PM

Hi there,

I have been through the LS300g manual a thousand times and configured both datalogger and modem as per instructed, including uploading LS300G_115200_Template.xml. I have set the modem to dynamic DNS (IPMANGER) using ACEManager and I have good signal strength and I have allowed access to Loggernet through Windows firewall.

Datalogger Information
    Datalogger Name: CR1000
    Datalogger Type: CR1000
IP Port Connection
    IP Address: xxxxxxxxxxxxxxx.eairlink.com:6785
Datalogger Settings
    PakBus Address: 1
    Security Code: 0
    Extra Response Time: 4s
    Max Time Online: 0h 0m 0s
Collection Schedule
    Scheduled Collection is OFF

What device port should I be setting for LS300/PPP using DEVCONFIG: 3001 or 6875?

At this point in time, I fear I cannot see the wood for the trees. Anyone clues would be greatly appreciated!

JDavis Nov 14, 2016 04:39 PM

The Device Port setting on the modem should be left at 3001. The port 6785 is the Pakbus TCP Server port default on the datalogger. In PPP mode, you won't be using the device port. Make sure the port forwarding rule is set in the modem firewall to pass port 6785 to the datalogger.

bugguts99 Nov 17, 2016 07:17 AM

Thanks for the response. With respect to "Make sure the port forwarding rule is set in the modem firewall to pass port 6785 to the datalogger" is this set with the internet IP address, as in: xxxxxxxxxxxxxxx.eairlink.com:6785. Does IP Manager work outside of the US? This system is located in Lao PDR.

JDavis Nov 17, 2016 03:49 PM

The IP manager will update anywhere in the world. Most international cellular service providers provide IP addresses that are behind firewalls. When that is the case, you need to talk with your service provider and they usually offer a public accessible IP for an additional fee.

bugguts99 Nov 21, 2016 09:30 AM

I have just met with CS Southest Asia who have told me the only current solution in Thailand is to obtain a static IP address. My guess is it will be the same for Laos so the next challenge is to explain my exact requirements to someone who will understand what I mean. Time to get my English-Lao dictionary out.

Thanks again.

GaryTRoberts Nov 22, 2016 04:30 AM

The datalogger can also call home using the TCPClient connection setting in the datalogger.  The datalogger must have an Ethernet or PPP interface setup and able to reach the internet.  The LoggerNet server on the other end must have a static TCP/IP address that has a public TCP/IP address or a hole punched throught a firewall with a public TCP/IP address.

Many users outside the OS that have dataloggers on private TCP/IP addresses us this method for getting and collecting data from their dataloggers.

novicok Nov 22, 2016 03:11 PM

I have same problem. Can you help me to solve communication problem with CR1000.

I installed last OS in data logger(CR1000 OS 30.01). I sent AT commands to Fastrack xtend modem and reset it.

I also reset CS105

only I did not change port 6785. But installed to my PC cports and see my Logger Net.exe is on the 6789

If i will replace 6785 to 6789 will I communicate with data logger by remote.

How can I know configuration  between CR1000 , CS105 and modem matche with each other

I only know after sending new OS to data logger PPP IP address is

Is it mean that,  every think is ok between them or not?

GaryTRoberts Nov 22, 2016 03:42 PM


No, changing the port number on the datalogger to 6789 will not help.  The setting for the PPP TCP/IP address tells the logger it is using DHCP.  That means it will get it's TCP/IP address, gateway, and DNS settings from the modem or cell network.  What does it show in the TCP/IP information fields in DevConfig?  That is where you will see what addresses the datalogger is getting. 

Are you sure you are using a CS105?  I have that listed as a barometer.

novicok Nov 22, 2016 04:39 PM

sorry this is SC105 interface.

how to solve comunication problem?

I am using sim card with static IP address.

where and what exuctly need to re-configurate?

Could you explain which parameters need to change.

Settings Editor - PPP- PPP interface CS I/O SCD7- PPP IP address PPP dial *99***1#- PPP dial resp. CONNECT

In the TCP/IP information

ppp ip:

ppp gw

dns srv 1:

dns srv 2:

do you mean this?


aps Nov 23, 2016 05:22 PM

A few tips from me:

1) make sure you have reconfigured the SC105 to run at 115200 baud  (out of the box it runs at 9600 baud)

2) the dial string for a PPP connection for the LS300, as is stated in our manual, is AT\APPP

3) this series of modems know about the network settings of many common networks, but it is unlikely to know about those in LAO especially if using a fixed IP service.   So you will need to find out the name of the APN to use and set it in the modem.

4) if you sourced the modem in the Americas and did not inform them you are using it in Lao then you may well have the US version that may not support the 3G (UTMS) frequencies in Asia.   It should work on the 2G networks if there is one available.

bugguts99 Nov 24, 2016 09:02 AM

Hi aps,

Thanks for the information...my enquiry ended in the third thread of this post. I believe it novicok had the questions related to the SC105, not I; I am using a CR1000.

All my gear was sourced through CS Southeast Asia, who knew the instruments were to be located in Laos, so I am hoping it will work. Problem is, finding the right colleague and telco provider who understands my requirements. I was in Bangkok on Monday and went through the process with the engineers there and it seems everything was in order. The problem is that dynamic DNS using IP Manager does not work in this region (CS Southeast Asia have the same problem), so I need a static IP, apparently. Still working on it....

aps Nov 24, 2016 11:37 AM

The issue with the Airlink or any other dynamic IP manager is that on many networks, especially outside the USA, the modem is allocated a private IP address and is behind a firewall/router so you cannot connect to it using whatever IP address these tools give you (which can be the private address but more often is that of the router).

You will need to either get a fixed IP SIM card, where you either get a public fixed IP that is routed to the modem, or a fixed IP provided via a VPN tunnel.   The alternative is to set the logger up to call back to Loggernet or use our Konect routing service, see: https://www.campbellsci.eu/konect-pakbus-router

aps Oct 23, 2021 07:00 AM

The link to the Pakbus routing service has changed and is now: KonectPBRouter: PakBus Routing Service (campbellsci.eu)

This service is included as a complentary service with some modems purchased from Campbell Scientific.

Log in or register to post/reply in the forum.